Technical Requirements for Users

BioSig-ID works on a wide variety of operating systems, browsers and devices. The following lists the currently supported system requirements for end-users.

If you do not have the basic requirements on the system you are trying to use, you will not be able to create a profile. Please find another system that meets the requirements or if you are not able to do this, please contact the institution that requested you create a BioSig-ID profile.

Supported Operating Systems:

Any OS that can run a W3C HTML5 compliant browser

  • Microsoft Windows XP, Vista, 7, 8, 8.1
  • Mac OS X 10.6.x, current release 10.8.4
  • Ubuntu LINUX 12+, current release 13.04
  • Android 2.1+, current release 4.3

 Supported Browsers:

Any W3C HTML5 compliant browser**

  • Microsoft Internet Explorer 8+, current release 10.0.9200.16660
  • Mozilla Firefox 3+, current release 23.0
  • Google Chrome 4+, current release 28.0.1500.95
  • Apple Safari 6+, current release 6.0.5
  • Opera 9+, current release 15.0.1147.153

 * Adobe Flash is used as fallback when HTML5 fails, current release 11.8.800.94

 For the mobile version:

  • iPhone 4 and higher
  • Android 2.3 and higher

Supported Input Methods:

Any input method that allows the user to draw and select

  • Mouse
  • Stylus
  • Touchpad
  • Touchscreen
Have more questions? Submit a request

0 Comments

Article is closed for comments.
Powered by Zendesk